Using subtree with vcsh and mr?

Michael McCracken michael.mccracken at
Fri Aug 8 16:34:09 CEST 2014

Hi, I've been happily using vcsh and mr for a while, to manage my emacs,
zsh, git & bzr configs.

I've hit a problem with integrating third-party code that works with e.g.
emacs or zsh.
I suspect I'm missing a straightforward way to solve this, but in searching
through the vcsh issues on github, it seems like it wasn't solved (or no
one updated the issue, #27 [1]).

For example, useful stuff like zsh-git-prompt [2] just has a top-level repo
with files in it, so if I directly add it as a main repo in vcsh, I'll just
get those files dumped into $HOME. For that one, I 'solved' it by forking
and creating the directory structure I wanted [3]. However, that's going to
be a pain for anything that's more actively developed.

For example, emacs-helm [4] is really useful, and it's actively developed,
but look at all those files in the top level just flooding $HOME.

Any tips?



More information about the vcs-home mailing list